using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\w+(?:,\s*\w+(?:\s+and\s+\w+)?)+,?\s*(and|or)";
string input = @"a, b, c and d, or e
a, b, c and d, or e but not f, g, h and i, or j
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}