// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)\w+(?:,\s*\w+(?:\s+and\s+\w+)?)+,?\s*(and|or)").unwrap();
let string = "a, b, c and d, or e
a, b, c and d, or e but not f, g, h and i, or j
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}