$re = '/\w+(?:,\s*\w+(?:\s+and\s+\w+)?)+,?\s*(and|or)/m';
$str = 'a, b, c and d, or e
a, b, c and d, or e but not f, g, h and i, or j
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);