const regex = /\w+(?:,\s*\w+(?:\s+and\s+\w+)?)+,?\s*(and|or)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\w+(?:,\\s*\\w+(?:\\s+and\\s+\\w+)?)+,?\\s*(and|or)', 'gm')
const str = `a, b, c and d, or e
a, b, c and d, or e but not f, g, h and i, or j
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}