re = /\w+(?:,\s*\w+(?:\s+and\s+\w+)?)+,?\s*(and|or)/m
str = 'a, b, c and d, or e
a, b, c and d, or e but not f, g, h and i, or j
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end