import re
regex = re.compile(r"\w+(?:,\s*\w+(?:\s+and\s+\w+)?)+,?\s*(and|or)", flags=re.MULTILINE)
test_str = ("a, b, c and d, or e\n"
"a, b, c and d, or e but not f, g, h and i, or j\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")