#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "<a[^>]*?href=(?|"([^"]*?)").*?>(.*)\s+("([^"]|"")*")\s+(.*)|("([^"]|"")*")\s+(.*)|("([^"]|"")*")|(.*)\s+(“([^“]|””)*”)\s+(.*)|(“([^“]|””)*”)\s+(.*)|(“([^“]|””)*”)<\/a>"
Local $sString = "<a href="bla">123 "this" is asd</a>" & @CRLF & _
"<a href="bla">this should not be captured</a>" & @CRLF & _
"<a href="bla">no quotes in anchor text here</a>" & @CRLF & _
"<a href="bla">"445 is in quotes"</a>" & @CRLF & _
"<a href="bla">asd "blabla" sometimes</a>" & @CRLF & _
"<a href="bla">something with quotes like “blabla” is bad</a>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")