using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<a[^>]*?href=(?|""([^""]*?)"").*?>(.*)\s+(""([^""]|"")*"")\s+(.*)|(""([^""]|"")*"")\s+(.*)|(""([^""]|"")*"")|(.*)\s+(“([^“]|””)*”)\s+(.*)|(“([^“]|””)*”)\s+(.*)|(“([^“]|””)*”)<\/a>";
string input = @"<a href=""bla"">123 ""this"" is asd</a>
<a href=""bla"">this should not be captured</a>
<a href=""bla"">no quotes in anchor text here</a>
<a href=""bla"">""445 is in quotes""</a>
<a href=""bla"">asd ""blabla"" sometimes</a>
<a href=""bla"">something with quotes like “blabla” is bad</a>";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}