import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<a[^>]*?href=(?|\"([^\"]*?)\").*?>(.*)\\s+(\"([^\"]|\"\")*\")\\s+(.*)|(\"([^\"]|\"\")*\")\\s+(.*)|(\"([^\"]|\"\")*\")|(.*)\\s+(“([^“]|””)*”)\\s+(.*)|(“([^“]|””)*”)\\s+(.*)|(“([^“]|””)*”)<\\/a>";
final String string = "<a href=\"bla\">123 \"this\" is asd</a>\n"
+ "<a href=\"bla\">this should not be captured</a>\n"
+ "<a href=\"bla\">no quotes in anchor text here</a>\n"
+ "<a href=\"bla\">\"445 is in quotes\"</a>\n"
+ "<a href=\"bla\">asd \"blabla\" sometimes</a>\n"
+ "<a href=\"bla\">something with quotes like “blabla” is bad</a>";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}