use strict;
my $str = '<a href="bla">123 "this" is asd</a>
<a href="bla">this should not be captured</a>
<a href="bla">no quotes in anchor text here</a>
<a href="bla">"445 is in quotes"</a>
<a href="bla">asd "blabla" sometimes</a>
<a href="bla">something with quotes like “blabla” is bad</a>';
my $regex = qr/<a[^>]*?href=(?|"([^"]*?)").*?>(.*)\s+("([^"]|"")*")\s+(.*)|("([^"]|"")*")\s+(.*)|("([^"]|"")*")|(.*)\s+(“([^“]|””)*”)\s+(.*)|(“([^“]|””)*”)\s+(.*)|(“([^“]|””)*”)<\/a>/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}