$re = '/<a[^>]*?href=(?|"([^"]*?)").*?>(.*)\s+("([^"]|"")*")\s+(.*)|("([^"]|"")*")\s+(.*)|("([^"]|"")*")|(.*)\s+(“([^“]|””)*”)\s+(.*)|(“([^“]|””)*”)\s+(.*)|(“([^“]|””)*”)<\/a>/';
$str = '<a href="bla">123 "this" is asd</a>
<a href="bla">this should not be captured</a>
<a href="bla">no quotes in anchor text here</a>
<a href="bla">"445 is in quotes"</a>
<a href="bla">asd "blabla" sometimes</a>
<a href="bla">something with quotes like “blabla” is bad</a>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);