re = /<a[^>]*?href=(?|"([^"]*?)").*?>(.*)\s+("([^"]|"")*")\s+(.*)|("([^"]|"")*")\s+(.*)|("([^"]|"")*")|(.*)\s+(“([^“]|””)*”)\s+(.*)|(“([^“]|””)*”)\s+(.*)|(“([^“]|””)*”)<\/a>/
str = '<a href="bla">123 "this" is asd</a>
<a href="bla">this should not be captured</a>
<a href="bla">no quotes in anchor text here</a>
<a href="bla">"445 is in quotes"</a>
<a href="bla">asd "blabla" sometimes</a>
<a href="bla">something with quotes like “blabla” is bad</a>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end