const regex = /<a[^>]*?href=(?|"([^"]*?)").*?>(.*)\s+("([^"]|"")*")\s+(.*)|("([^"]|"")*")\s+(.*)|("([^"]|"")*")|(.*)\s+(“([^“]|””)*”)\s+(.*)|(“([^“]|””)*”)\s+(.*)|(“([^“]|””)*”)<\/a>/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('<a[^>]*?href=(?|"([^"]*?)").*?>(.*)\\s+("([^"]|"")*")\\s+(.*)|("([^"]|"")*")\\s+(.*)|("([^"]|"")*")|(.*)\\s+(“([^“]|””)*”)\\s+(.*)|(“([^“]|””)*”)\\s+(.*)|(“([^“]|””)*”)<\\\/a>', 'g')
const str = `<a href="bla">123 "this" is asd</a>
<a href="bla">this should not be captured</a>
<a href="bla">no quotes in anchor text here</a>
<a href="bla">"445 is in quotes"</a>
<a href="bla">asd "blabla" sometimes</a>
<a href="bla">something with quotes like “blabla” is bad</a>`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}