#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(\+\+)(\w+)"
Local $sString = "function smallestDivisor(num) {" & @CRLF & _
" function process(num, divisor) {" & @CRLF & _
" if (num === 1) {" & @CRLF & _
" return 1;" & @CRLF & _
" }" & @CRLF & _
" if (num === 0) {" & @CRLF & _
" return 0;" & @CRLF & _
" }" & @CRLF & _
" if (num % divisor === 0) {" & @CRLF & _
" return divisor;" & @CRLF & _
" }" & @CRLF & _
" if (divisor === num) return num;" & @CRLF & _
" return process(num, ++divisor );" & @CRLF & _
" }" & @CRLF & _
" return process(num, 2);" & @CRLF & _
"}" & @CRLF & _
"console.log(smallestDivisor(25));"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")