import re
regex = re.compile(r"(\+\+)(\w+)", flags=re.MULTILINE)
test_str = ("function smallestDivisor(num) {\n"
" function process(num, divisor) {\n"
" if (num === 1) {\n"
" return 1;\n"
" }\n"
" if (num === 0) {\n"
" return 0;\n"
" }\n"
" if (num % divisor === 0) {\n"
" return divisor;\n"
" }\n"
" if (divisor === num) return num;\n"
" return process(num, ++divisor );\n"
" }\n"
" return process(num, 2);\n"
"}\n"
"console.log(smallestDivisor(25));")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")