const regex = /(\+\+)(\w+)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\\+\\+)(\\w+)', 'gm')
const str = `function smallestDivisor(num) {
function process(num, divisor) {
if (num === 1) {
return 1;
}
if (num === 0) {
return 0;
}
if (num % divisor === 0) {
return divisor;
}
if (divisor === num) return num;
return process(num, ++divisor );
}
return process(num, 2);
}
console.log(smallestDivisor(25));`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}