using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\+\+)(\w+)";
string input = @"function smallestDivisor(num) {
function process(num, divisor) {
if (num === 1) {
return 1;
}
if (num === 0) {
return 0;
}
if (num % divisor === 0) {
return divisor;
}
if (divisor === num) return num;
return process(num, ++divisor );
}
return process(num, 2);
}
console.log(smallestDivisor(25));";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}