import Foundation
let pattern = #"(\+\+)(\w+)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
function smallestDivisor(num) {
function process(num, divisor) {
if (num === 1) {
return 1;
}
if (num === 0) {
return 0;
}
if (num % divisor === 0) {
return divisor;
}
if (divisor === num) return num;
return process(num, ++divisor );
}
return process(num, 2);
}
console.log(smallestDivisor(25));
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)