$re = '/(\+\+)(\w+)/m';
$str = 'function smallestDivisor(num) {
function process(num, divisor) {
if (num === 1) {
return 1;
}
if (num === 0) {
return 0;
}
if (num % divisor === 0) {
return divisor;
}
if (divisor === num) return num;
return process(num, ++divisor );
}
return process(num, 2);
}
console.log(smallestDivisor(25));';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);