use strict;
my $str = 'function smallestDivisor(num) {
function process(num, divisor) {
if (num === 1) {
return 1;
}
if (num === 0) {
return 0;
}
if (num % divisor === 0) {
return divisor;
}
if (divisor === num) return num;
return process(num, ++divisor );
}
return process(num, 2);
}
console.log(smallestDivisor(25));';
my $regex = qr/(\+\+)(\w+)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}