using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"6\/([1-9]|1[0-9]|2[0-9]|30)\/[0-9]{2}$|^[7-8]\/([1-9]|1[0-9]|2[0-9]|3[0-1])\/[0-9]{2}";
string input = @"col5date
7/4/22
8/29/22
10/9/22
12/12/20
9/1/19
9/1/22
9/22/19
2/16/22
6/16/22";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}