const regex = /6\/([1-9]|1[0-9]|2[0-9]|30)\/[0-9]{2}$|^[7-8]\/([1-9]|1[0-9]|2[0-9]|3[0-1])\/[0-9]{2}/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('6\\\/([1-9]|1[0-9]|2[0-9]|30)\\\/[0-9]{2}$|^[7-8]\\\/([1-9]|1[0-9]|2[0-9]|3[0-1])\\\/[0-9]{2}', 'gm')
const str = `col5date
7/4/22
8/29/22
10/9/22
12/12/20
9/1/19
9/1/22
9/22/19
2/16/22
6/16/22`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}