package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)6\/([1-9]|1[0-9]|2[0-9]|30)\/[0-9]{2}$|^[7-8]\/([1-9]|1[0-9]|2[0-9]|3[0-1])\/[0-9]{2}`)
var str = `col5date
7/4/22
8/29/22
10/9/22
12/12/20
9/1/19
9/1/22
9/22/19
2/16/22
6/16/22`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}