import re
regex = re.compile(r"6\/([1-9]|1[0-9]|2[0-9]|30)\/[0-9]{2}$|^[7-8]\/([1-9]|1[0-9]|2[0-9]|3[0-1])\/[0-9]{2}", flags=re.MULTILINE)
test_str = ("col5date\n"
"7/4/22\n"
"8/29/22\n"
"10/9/22\n"
"12/12/20\n"
"9/1/19\n"
"9/1/22\n"
"9/22/19\n"
"2/16/22\n"
"6/16/22")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")