#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?s)(<STYLE>).*(<\/STYLE>)"
Local $sString = " <STYLE>" & @CRLF & _
" group 1" & @CRLF & _
" </STYLE>" & @CRLF & _
" Random text here which shall not be removed." & @CRLF & _
" <STYLE>" & @CRLF & _
" group 2" & @CRLF & _
" </STYLE>" & @CRLF & _
" Some more random text here which shall not be removed." & @CRLF & _
" <STYLE>" & @CRLF & _
" group 3" & @CRLF & _
" </STYLE>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")