import re
regex = re.compile(r"(<STYLE>).*(<\/STYLE>)", flags=re.DOTALL)
test_str = (" <STYLE>\n"
" group 1\n"
" </STYLE>\n"
" Random text here which shall not be removed.\n"
" <STYLE>\n"
" group 2\n"
" </STYLE>\n"
" Some more random text here which shall not be removed.\n"
" <STYLE>\n"
" group 3\n"
" </STYLE>")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")