const regex = /(<STYLE>).*(<\/STYLE>)/sg;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(<STYLE>).*(<\\\/STYLE>)', 'sg')
const str = ` <STYLE>
group 1
</STYLE>
Random text here which shall not be removed.
<STYLE>
group 2
</STYLE>
Some more random text here which shall not be removed.
<STYLE>
group 3
</STYLE>`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}