package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?s)(<STYLE>).*(<\/STYLE>)`)
var str = ` <STYLE>
group 1
</STYLE>
Random text here which shall not be removed.
<STYLE>
group 2
</STYLE>
Some more random text here which shall not be removed.
<STYLE>
group 3
</STYLE>`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}