re = /(<STYLE>).*(<\/STYLE>)/
str = ' <STYLE>
group 1
</STYLE>
Random text here which shall not be removed.
<STYLE>
group 2
</STYLE>
Some more random text here which shall not be removed.
<STYLE>
group 3
</STYLE>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end