using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"((\d{3}|\(\d{3}\))?)(\s|-|\.?)\d{3}(\s|-|\.)\d{4}(\s*(ext|x|ext.)\s*(\d{2,5})?)";
string input = @"123-231-3333 ext 12345";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}