import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "((\\d{3}|\\(\\d{3}\\))?)(\\s|-|\\.?)\\d{3}(\\s|-|\\.)\\d{4}(\\s*(ext|x|ext.)\\s*(\\d{2,5})?)";
final String string = "123-231-3333 ext 12345";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}