#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?:\G(?!^)|!)(?:[^:\n]*:)+?\K\d{6}"
Local $sString = ":123456" & @CRLF & _
"23/06/2021!06:31:00!872701!4125:063100,4143,101,207,225,229,303,325,329,441:252222" & @CRLF & _
":123456" & @CRLF & _
"abcdef:123456" & @CRLF & _
"23/06/2021!06:31:00!872701!4125:063100,4143,101,207,225,229,303,325,329,441:252222" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")