const regex = /(?:\G(?!^)|!)(?:[^:\n]*:)+?\K\d{6}/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:\\G(?!^)|!)(?:[^:\\n]*:)+?\\K\\d{6}', 'g')
const str = `:123456
23/06/2021!06:31:00!872701!4125:063100,4143,101,207,225,229,303,325,329,441:252222
:123456
abcdef:123456
23/06/2021!06:31:00!872701!4125:063100,4143,101,207,225,229,303,325,329,441:252222
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}