re = /(?:\G(?!^)|!)(?:[^:\n]*:)+?\K\d{6}/
str = ':123456
23/06/2021!06:31:00!872701!4125:063100,4143,101,207,225,229,303,325,329,441:252222
:123456
abcdef:123456
23/06/2021!06:31:00!872701!4125:063100,4143,101,207,225,229,303,325,329,441:252222
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end