using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:\G(?!^)|!)(?:[^:\n]*:)+?\K\d{6}";
string input = @":123456
23/06/2021!06:31:00!872701!4125:063100,4143,101,207,225,229,303,325,329,441:252222
:123456
abcdef:123456
23/06/2021!06:31:00!872701!4125:063100,4143,101,207,225,229,303,325,329,441:252222
";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}