use strict;
my $str = ':123456
23/06/2021!06:31:00!872701!4125:063100,4143,101,207,225,229,303,325,329,441:252222
:123456
abcdef:123456
23/06/2021!06:31:00!872701!4125:063100,4143,101,207,225,229,303,325,329,441:252222
';
my $regex = qr/(?:\G(?!^)|!)(?:[^:\n]*:)+?\K\d{6}/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}