import re
regex = re.compile(r"(?:\G(?!^)|!)(?:[^:\n]*:)+?\K\d{6}")
test_str = (":123456\n"
"23/06/2021!06:31:00!872701!4125:063100,4143,101,207,225,229,303,325,329,441:252222\n"
":123456\n"
"abcdef:123456\n"
"23/06/2021!06:31:00!872701!4125:063100,4143,101,207,225,229,303,325,329,441:252222\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")