import Foundation
let pattern = #"(?:\G(?!^)|!)(?:[^:\n]*:)+?\K\d{6}"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
:123456
23/06/2021!06:31:00!872701!4125:063100,4143,101,207,225,229,303,325,329,441:252222
:123456
abcdef:123456
23/06/2021!06:31:00!872701!4125:063100,4143,101,207,225,229,303,325,329,441:252222
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)