using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\d{2,}|[[:alpha:]]{2,})";
string input = @"12345, pwd45678, pwd_abcdef, pwd_abc123,
o1k2a3y, f1i2n3e4";
RegexOptions options = RegexOptions.CultureInvariant;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}