use strict;
my $str = '12345, pwd45678, pwd_abcdef, pwd_abc123,
o1k2a3y, f1i2n3e4';
my $regex = qr/(\d{2,}|[[:alpha:]]{2,})/up;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}