package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(\d{2,}|[[:alpha:]]{2,})`)
var str = `12345, pwd45678, pwd_abcdef, pwd_abc123,
o1k2a3y, f1i2n3e4`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}