$re = '/(\d{2,}|[[:alpha:]]{2,})/u';
$str = '12345, pwd45678, pwd_abcdef, pwd_abc123,
o1k2a3y, f1i2n3e4';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);