re = /(\d{2,}|[[:alpha:]]{2,})/
str = '12345, pwd45678, pwd_abcdef, pwd_abc123,
o1k2a3y, f1i2n3e4'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end