// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?u)(\d{2,}|[[:alpha:]]{2,})").unwrap();
let string = "12345, pwd45678, pwd_abcdef, pwd_abc123,
o1k2a3y, f1i2n3e4";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}