const regex = /(\d{2,}|[[:alpha:]]{2,})/gu;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\\d{2,}|[[:alpha:]]{2,})', 'gu')
const str = `12345, pwd45678, pwd_abcdef, pwd_abc123,
o1k2a3y, f1i2n3e4`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}