using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(this is.{0,2}(an.{0,2})?)?(example sentence)";
string input = @"blah blah. An example sentence
blah blah. This is an example sentence
Something something Example sentence ";
RegexOptions options = RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}