re = /(this is.{0,2}(an.{0,2})?)?(example sentence)/i
str = 'blah blah. An example sentence
blah blah. This is an example sentence
Something something Example sentence '
# Print the match result
str.scan(re) do |match|
puts match.to_s
end