package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?i)(this is.{0,2}(an.{0,2})?)?(example sentence)`)
var str = `blah blah. An example sentence
blah blah. This is an example sentence
Something something Example sentence `
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}