const regex = /(this is.{0,2}(an.{0,2})?)?(example sentence)/gi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(this is.{0,2}(an.{0,2})?)?(example sentence)', 'gi')
const str = `blah blah. An example sentence
blah blah. This is an example sentence
Something something Example sentence `;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}