// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?i)(this is.{0,2}(an.{0,2})?)?(example sentence)").unwrap();
let string = "blah blah. An example sentence
blah blah. This is an example sentence
Something something Example sentence ";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}